[Gta04-owner] QtMoko mic volume

Radek Polak psonek2 at seznam.cz
Sat Aug 25 07:58:32 CEST 2012


On Saturday, August 25, 2012 12:30:50 AM Neil Jerram wrote:

> Your one.
> 
> Then I realised I should just fetch Radek's repository too and look for
> any differences between his v3.2-gta04-qtmoko-v47 and your 3.2-gta04.
> As well as your recent sensor work, the big difference was the use of an
> initramfs; I guess there are probably aspects of the boot process or
> QtMoko rootfs that rely on that.

Thanks to initramfs QtMoko can boot from ext4. If you want to use Neil's 
kernel & config you will need ext3 on mmcblk0p2. It works normally with QtMoko.

> Anyway, finally I have good news.  After building Radek's
> v3.2-gta04-qtmoko-v47 kernel - except without Andreas's patch ([1]
> above) - and also after reverting the corresponding alsa state change in
> the QtMoko rootfs [2], audio works again in both directions of a phone
> call.  So I think [1] was what broke audio for GTA04A3; reverting [2] is
> needed because [1] adds more mixer controls and so changes what is
> needed in the state files.

If the problem is really the HW sound routing patch, then we need to fix it up. 
Maybe we can add these new controls only for A4.

Having two sets of alsa states is not a problem - QtMoko already uses different 
state files for A3 and A4 (earpiece.state / earpiecehw.state).

Regards

Radek

[1] 
https://github.com/radekp/qtmoko/tree/master/devices/gta04/src/plugins/audiohardware/neo


More information about the Gta04-owner mailing list