[Gta04-owner] Replicant GTA04 Install & Build instructions

Kevin Hremeviuc khremeviuc at yahoo.com
Tue Aug 21 13:08:54 CEST 2012


Hi Paul,

I have had several goes at building and installing using your
instructions. No problems with the build but once I have installed
Android it just doesn't run. I have tried the 2 build methods and
nothing works. 

I have to say that the 2 different build methods (sdcard and nand) and
then the replicant install script with the 'install' and 'system'
options confuse me. My initial assumption was that the script is meant
to be used with the sdcard build. Is that correct? And that the boot
image and the like are being flashed to nand, and the kernel will look
to the sdcard for all file system related stuff?

I have had the replicant repository for a while now and managed to build
and install it in the past (and it ran) by using the
qtmoko-fat-v45.tar.gz boot kit installed into an initial vfat partition
and then fiddling an init.rc file or similar to remap the partitions
appropriately. I may have modified something else but can't remember
what off the top of my head. 

Any ideas on what I may have done wrong?

I am happy to help out with the testing of the build and installation
processes. Just let me know when you have something to test and I'll
give it a go.

Thanks

Kev


On Wed, 2012-08-15 at 15:54 +0200, Paul Kocialkowski wrote:
> As I'm planning to release images of Replicant for GTA04 soon (basically
> as soon as calls and SMS work, along with a few more things), I have
> made some improvements to make it easier to install Replicant on GTA04,
> with an installer script, a dedicated boot.scr, status on leds and such.
> Installation currently takes place on sdcard. 
> 
> Detailed instructions on how to install are:
> http://redmine.replicant.us/projects/replicant/wiki/GTA04Installation
> As well as build instructions:
> http://redmine.replicant.us/projects/replicant/wiki/GTA04Build
> 




More information about the Gta04-owner mailing list