[Gta04-owner] Modem voice hardware routing

Benjamin Deering ben_deering at swissmail.org
Wed Aug 15 01:53:52 CEST 2012


On 08/11/2012 04:40 AM, Radek Polak wrote:
> On Saturday, August 11, 2012 12:05:30 AM Paul Kocialkowski wrote:
>
>> So what is the current state of hardware voice routing to the modem?
>> Replicant still uses an old 3.2 kernel from Neil's repo, with the
>> Android patches on top. Are there any patches that are needed to have
>> hardware voice routing working? What are the controls to use, etc?
> HW routing works perfectly. I am using it everyday. You need this [1] kernel
> patch and this [2] alsa state file.
>
> Just restore the state with:
>
> 	alsactl -f gsmearpiecehw.state restore
>
> make a call and enjoy good quality echo free sound with loud volume. Maybe the
> mic could be raised a bit - one friend of mine comlained he does not hear me
> well, but he was the only one, so i didnt have enough motivation raising it
> yet.
>
> Regards
>
> Radek
>
> [1]
> https://github.com/radekp/linux-2.6/commit/f43ce5c444de7db988ad214257f4a6ac0e49308d
>
> [2]
> https://github.com/radekp/qtmoko/blob/master/devices/gta04/src/plugins/audiohardware/neo/gsmearpiecehw.state
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner
>
It looks like the new 'Voice Route' control added by this patch cannot 
be switched while sound is playing.  This is why qtmoko had issues with 
no sound on calls if the phone rings.  I see this same behavior in my 
modifed SHR.  If the inability to switch is part of the hardware, we 
will need to stop playing the ringtone, then switch the voicerouting.


More information about the Gta04-owner mailing list