[Gta04-owner] xf86-video-omap

Neil Jerram neil at ossau.homelinux.net
Wed Oct 26 23:24:32 CEST 2011


On Sat, 22 Oct 2011 17:23:00 +0100, Neil Jerram wrote:

> Adding "omapfb.rotate=3 omapfb.vrfb=y", I again see the small Linux
> penguin rotated, but this time the Linux boot screen is stable, and
> eventually I even see the console login prompt appearing.  A fraction
> of a second after that, though, the whole screen goes yellow, and
> stays like that.

I have a little more to report about this - i.e. attempting to get a 
landscape UI.

I noticed (via ssh) that after X has started up, $(cat 
/sys/devices/platform/omapdss/overlay0/output_size) had changed to 
"640,480", whereas before - when showing the Linux boot screen - it was 
"480,640".  The following commands can be used to change it back to 
"480,640":

echo 0 > /sys/devices/platform/omapdss/overlay0/enabled
echo "480,640" > /sys/devices/platform/omapdss/overlay0/output_size
echo 1 > /sys/devices/platform/omapdss/overlay0/enabled

Then the uniform yellow disappears and is replaced by a garbled version 
of the blue LXDE desktop.  The nature of the garbling is that only about 
the top half of the (landscape-oriented) screen is predominantly blue, 
and no details within this can be clearly made out; the bottom half of 
the screen is black.  In other words it looks as though the whole 
desktop is somehow being mapped incorrectly to just the top half of the 
screen.

But nevertheless, setting output_size to "480,640" seems to be a step 
in the right direction.

Then I thought this (incorrect output_size setting) might be a bug in 
the X omap driver (xserver-xorg-video-omap3) and that it would be worth 
trying the Debian testing version instead of stable.  Perhaps unwisely, 
I did a general upgrade to testing, and the result now is that I can't 
ssh into the new system...  (The 192.168.0.202 address responds to ping, 
so I think this is just an SSH config problem.  Probably I can fix it by 
editing the SD card on my laptop, but I haven't looked at that yet.)  I 
didn't change the kernel at all.

I may put this landscape UI attempt on the backburner for a while now, 
but if anyone has comments or suggestions, they would be welcome.

Regards,
         Neil



More information about the Gta04-owner mailing list