[Gta04-owner] Linux 3.2-rc2 on GTA04

Johannes Schauer j.schauer at email.de
Fri Nov 25 00:13:08 CET 2011


Hi,

sorry for the wait but my battery died and I'm recharging them using my
nokia phone since apparently my gta04 refuses to charge them.

On Fri, Nov 25, 2011 at 09:54:10AM +1100, NeilBrown wrote:
> So you don't see::
> 
> [   20.786285] td028ttec1_panel_enable()
> [   20.790069] gta04_enable_lcd()
> 
> at all?

there is, earlier in the boot process (this is probably why i can see
the penguin properly)

[   19.072143] Console: switching to colour frame buffer device 128x48
[   19.091003] td028ttec1_panel_enable()
[   19.094818] gta04_enable_lcd()
[   19.114501] td028ttec1_panel_resume()
[   19.333587] driver: 'omapfb': driver_bound: bound to device 'omapfb'

> That is strange - I do.
> 
> What do you find in   
>     /sys/devices/omapdss/display0/
> 
> In particular, what is 'enabled' ?


root at goldel-gta04:~# find /sys/devices/omapdss/display0/
/sys/devices/omapdss/display0/
/sys/devices/omapdss/display0/uevent
/sys/devices/omapdss/display0/name
/sys/devices/omapdss/display0/subsystem
/sys/devices/omapdss/display0/power
/sys/devices/omapdss/display0/power/runtime_status
/sys/devices/omapdss/display0/power/control
/sys/devices/omapdss/display0/power/runtime_suspended_time
/sys/devices/omapdss/display0/power/runtime_active_time
/sys/devices/omapdss/display0/power/autosuspend_delay_ms
/sys/devices/omapdss/display0/driver
/sys/devices/omapdss/display0/enabled
/sys/devices/omapdss/display0/tear_elim
/sys/devices/omapdss/display0/timings
/sys/devices/omapdss/display0/rotate
/sys/devices/omapdss/display0/mirror
/sys/devices/omapdss/display0/wss
root at goldel-gta04:~# for f in `find /sys/devices/omapdss/display0/ -type f`; do echo $f=`cat $f`; done
/sys/devices/omapdss/display0/uevent=DRIVER=td028ttec1_panel
/sys/devices/omapdss/display0/name=lcd
/sys/devices/omapdss/display0/power/runtime_status=unsupported
/sys/devices/omapdss/display0/power/control=auto
/sys/devices/omapdss/display0/power/runtime_suspended_time=0
/sys/devices/omapdss/display0/power/runtime_active_time=0
cat: /sys/devices/omapdss/display0/power/autosuspend_delay_ms: Input/output error
/sys/devices/omapdss/display0/power/autosuspend_delay_ms=
/sys/devices/omapdss/display0/enabled=1
/sys/devices/omapdss/display0/tear_elim=0
/sys/devices/omapdss/display0/timings=45473,1024/24/56/160,768/8/33/8
cat: /sys/devices/omapdss/display0/rotate: No such file or directory
/sys/devices/omapdss/display0/rotate=
cat: /sys/devices/omapdss/display0/mirror: No such file or directory
/sys/devices/omapdss/display0/mirror=
cat: /sys/devices/omapdss/display0/wss: No such file or directory
/sys/devices/omapdss/display0/wss=

> The only reason I can see for it no running td028ttec1_panel_enable is
> if it thinks the panel is already enabled.

> > what fixed this issue for the 3.1 kernel was:
> > https://gitorious.org/gta04/gta04-kernel/commit/0e0a2d8bb2461c3effe3a01955f65118b4f63177
> > but i guess the video= argument is now replaced by omapfb.mode ?
> 
> I'll add that to my list ;-)

thanks :D

cheers, josch


More information about the Gta04-owner mailing list