[Gta04-owner] Linux 3.2-rc2 on GTA04

NeilBrown neilb at suse.de
Thu Nov 24 23:49:30 CET 2011


On Thu, 24 Nov 2011 23:40:09 +0100 Johannes Schauer <j.schauer at email.de>
wrote:

> Hi,
> 
> On Fri, Nov 25, 2011 at 09:20:36AM +1100, NeilBrown wrote:
> > Something strange here.  Glad that the GPIO pin is clearly working,
> > but cannot imagine why it isn't being turned on.
> > 
> > How do "gta04_enable_lcd" and "gta04_disable_lcd" dmesg messages align with
> > the other events.
> > In particular, when the display is dark and you tap the display, do you get
> > the message "gta04_enable_lcd" even though it doesn't turn on the backlight,
> > or do you not get the message at all?
> 
> after bootup (me doing nothing - just xorg loading):
> 
> [   50.105957] td028ttec1_panel_suspend()
> [   50.131927] gta04_disable_lcd()
> [   50.911926] td028ttec1_panel_resume()
> 
> then I do
> 
> 	echo 1 > /sys/class/gpio/gpio57/value
> 
> to turn it on (works)
> 
> when the display suspends after a 10 minute timeout (works and gets dark):
> 
> [  355.885772] td028ttec1_panel_suspend()
> [  355.898132] gta04_disable_lcd()
> 
> then I tap the display (backlight doesnt turn on):
> 
> [  368.835754] td028ttec1_panel_resume()
> 
> then I do
> 
> 	echo 1 > /sys/class/gpio/gpio57/value
> 
> to turn it on (works)
> 

So you don't see:
> > (Also - glad to know the touch screen and display and all is basically
> > working - that is all in upstream code now.  David's kernel had lots of
> > display related patches that I don't need because Linus has them!).
> 
> indeed - the basic functionality is indeed there which is extremely great :)
> 
> 
> another thing i'm playing with is the display resolution. currently it
> omapfb.mode=lcd:640x480 which is of course wrong and distorts half of
> the display output. I changed it to omapfb.mode=lcd:480x640 which made
> the output of the linux penguin during bootup show up correctly but xorg
> is now believing to have a 1024x768 display - wtf?? of course one only
> sees the top left corner of the 1024x768 screen on the display...
> 
> what fixed this issue for the 3.1 kernel was:
> https://gitorious.org/gta04/gta04-kernel/commit/0e0a2d8bb2461c3effe3a01955f65118b4f63177
> but i guess the video= argument is now replaced by omapfb.mode ?
> 
> cheers, josch
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20111125/0edcc4f6/attachment.bin>


More information about the Gta04-owner mailing list