[Gta04-owner] Booting from NAND

Dr. H. Nikolaus Schaller hns at goldelico.com
Mon Nov 21 15:21:15 CET 2011


Am 21.11.2011 um 13:26 schrieb Radek Polak:

> On Monday 21 November 2011 08:59:47 Dr. H. Nikolaus Schaller wrote:
> 
>>> And one more question. I see that UMTS should be on /dev/ttyHS3, but it
>>> is not on mine system (because i dont use udev?). Can someone give me
>>> major and minor numbers so that i can create the devices nodes with
>>> mknod?
>> 
>> Hm. I think that it is not done by udev at all but the HSO driver.
>> 
>> Can you please check that lsusb shows the modem?
>> If yes, the driver should be loaded by USB probing and matching
>> and leave some traces in dmesg.
>> 
>> Do you have compiled your own kernel?
> 
> Hi, yes. I have my kernel, but i was missing modules. So now after modprobe 
> hso the device is there and i could even make call using the ATD command - so 
> this works now, thanks!

Great!

> 
>> There is one patch required for the EHCI driver. The reason is that
>> there is no 5V USB bus power for the Modem. Therefore, the standard
>> USB PHY chip does not recognize that the modem is available.
>> Therefore, we had to patch the driver to send some ULPI command
>> to the PHY chip to disable VBUS sensing:
>> 
>> https://github.com/goldelico/gta04-kernel/commit/c654169f357877288b9080fd00
>> 72723c47923484
> 
> Nice to see sources on github. Should i use this url for latest sources? I 
> think i used git on gta04.org for previous version.

They are exchangeable and we push to both.

It is just that our (essentially fast) server for gta04.org is connected through
a slow DSL line and VPN tunnel.

(Who can recommend a really cheap SHDSL / FTTH service in Germany?)

Nikolaus


More information about the Gta04-owner mailing list