[Gta04-owner] New hw-validation snapshot

Christoph Mair christoph.mair at gmail.com
Thu Nov 17 10:35:16 CET 2011


On Thu, Nov 17, 2011 at 10:25 AM, Dr. H. Nikolaus Schaller
<hns at goldelico.com> wrote:
>
> Am 16.11.2011 um 22:51 schrieb Neil Jerram:
>
>> On 16.11.2011 21:10, Neil Jerram wrote:
>>> On 16.11.2011 20:56, Dr. H. Nikolaus Schaller wrote:
>>>
>>>> You do not need to reinstall the rootfs or reformat the SD card. Just
>>>> extract and replace the modified uImage and Xorg.conf (I hope
>>>> I did not forget anything).
>>>
>>> What about downloading and unpacking modules.tgz - would there be any
>>> changes in there?
>>
>> I'm afraid I'm still not getting real GPS information.  I guessed (from googling) that it might also need a further command:
>>
>> echo normal >/sys/devices/platform/reg-virt-consumer.5/mode
>>
>> but that made no difference.
>>
>> I haven't yet opened up my GTA04 to check the antenna connection, so it could still be a mechanical problem in my case.  Therefore it would be lovely to hear if anyone else can see real satellite or fix information with the new validation kernel.
>
> I tried yesterday on two devices and it wasn't very successful either.
> The power on/off did work (even without the "normal") and the /sys/gpio
> did indicate internal/external antenna switching.
>
> I got some UTC information from the satellites, but never got enough
> of them to get a position fix. So that is something which needs more analysis.
>
> Let's hope that we don't have a similar issue like the GTA02A5 where the
> MMC/SD slot did introduce some interferences. This is easy to solve but
> very difficult to identify.
Maybe its possible to boot use a initramfs to test the GPS reception.
This would eliminate all activities on the mmc data lines.

Regards,
  Christoph


More information about the Gta04-owner mailing list