[Gta04-owner] Charging battery from USB

Dr. H. Nikolaus Schaller hns at goldelico.com
Wed Nov 9 17:57:26 CET 2011


Hi,

Am 09.11.2011 um 17:42 schrieb Benjamin Kiessling:

> Hi,
> 
> I'd like to know if the battery charging bug of the GTA02 has been fixed
> in the GTA04. Is the battery being charged if USB is plugged in, but the
> phone is turned off? As far as I can tell it isn't charging but I
> wouldn't completely rule out major incompetence on my part.

Well, it depends...

In fact it appears to have a different bug than the GTA02A5 devices
did have. For the GTA02 it was solved in A6 and later units. I think some
capacitor was enlarged.

The GTA04 also has a problem with USB charging if the battery is
drained. A low voltage battery is being trickle charged with approx.
70 mA. After the power-on voltage (ca. 3.2V) is reached, the CPU switches on
but then draws approx. 100-400 mA. This of course discharges the
battery faster than it is being recharged. Depending on some chemical
effects in the battery and operational thresholds, it may still be
sufficient to boot the processor far enough that the software enables
a higher charging current (e.g. 500 mA).

So you may experience that it boots a little (seen on RS232) and
then shuts down after some seconds. After a while it will try again.

Recently, there was one report on this list that it did come farther
each time and after 4 cycles it continued charging.

So I would say it is different than in the GTA02.

Unfortunately this is a known bug of the TPS65950 PMU and the
errata by TI say "no workaround known".

Nikolaus



More information about the Gta04-owner mailing list