[Gta04-owner] battery holder

NeilBrown neilb at suse.de
Wed Dec 21 02:46:32 CET 2011


On Mon, 19 Dec 2011 22:01:15 +0100 Christoph Mair <christoph.mair at gmail.com>
wrote:

> On Mon, Dec 19, 2011 at 9:02 PM, NeilBrown <neilb at suse.de> wrote:
> > On Mon, 19 Dec 2011 18:14:35 +0100 Andreas Kemnade <andreas at kemnade.info>
> > wrote:
> >
> >> Hi,
> >>
> >> as there seems to be again problems with empty batteries and charging the
> >> gta04.
> >> I am thinking about printing a separate battery holder (I own a reprap) to be
> >> able to charge the battery externally. How do I make stable contacts to the
> >> battery? The electronics is not the problem.
> >>
> >> Or is the problem with empty batteries already solved? Unfortunately I have no
> >> GTA04 yet to try it out. I hope that situation changes in the next days.
> >
> > It isn't solved but I have hopes of solving 99% of the problem.
> >
> > My experience is that if you leave a flat battery for a while it will gather
> > up what charge it has and be able to deliver it - maybe only for a second.
> > That much time should be enough for uboot to enable the battery-charge
> > interface and run off USB power.
> >
> > So we would need to make sure that uboot enables charging very early, and
> > make sure that Linux doesn't disable charging - even for a moment.
> >
> > One problem with this is that it is not correct to draw current from a USB
> > cable unless we have determined that current is available, and determining
> > current availability from a PC is (I think) a bit more complicated than uboot
> > should be.  Detecting a charger is easy so you might need to use a charger to
> > charge a nearly-empty battery.   I still have stuff to learn here though.
> >
> > Currently the device doesn't charge when off because we turn the battery
> > charger off.   That should be easy enough to fix.
> The GTA04 will automatically charge the battery if you connect it to
> some USB Host. To meet the USB spec it charges only with 70mA, As soon
> as the battery voltage reaches a specified level (IIRC, 3.2V) the
> device will power on and try to boot.

Oh that's right - the "precharge" thing that the doco keeps talking about.
Thanks.

>                                        With neils current kernel it
> takes to long to get to the point where the kernel enables fast
> charging with 500mA and the GTA04 switches off again, but without all
> those debugging features it is no problem reaching that point.
> 

I left my phone on all night and let it drain the battery.  When I plugged it
in it sat for a few minutes and then booted perfectly.  So even with the
debugging it sometimes gets there in time.  So it's looking good.

BTW I like numbers and being a non-hardware person I choose units like
"percent per hour" to measure current on my phone rather than amps.
I made some measurements:

 With the bare board - no display, no antenna - using my latest kernel the
   battery loses charge at 30%/hour (so flat in a little over 3 hours).
 With the USB cable connected from a PC it gains change at about 25%/hour.
 So if it could fast-charge while otherwise 'off' it should charge at
 about 50%/hour (which implies 600mA charging, which I read somewhere).
 In 'suspend' mode it currently loses 13%/hour so 8 hours stand-by time.

So it is definitely entering suspend but hopefully there are a lot more
things we can turn off.  I haven't even tried turning more things off yet,
so one LED was on the whole time.

I guess we are hoping for under 2%/hour.  We are a long way from there, but
it good to know what the starting point is!



> You can also prevent it from booting linux, and type "systest charge"
> into your u-boot console. This enables fast charging.
> 
> > Also the gta04 board has the  possibility for being provided stable current
> > and booting from that with no battery.  This current comes in through the
> > same port that the serial cable is connected to.  I cannot think of a way to
> > provide power through that port but if you could, you could charge a
> > completely flat battery.
> 
> This is supposed to work, but due to a bug inside the TPS power
> management chip it does not work. Texas Instruments has documented
> this errata with "no workaround known". Charging the battery using
> this method works fine. The input voltage should be about 5V. Absolute
> max is 6.5V IIRC. Make sure you get the polarity right.

Ahh.. that is the errata I have heard mentioned but never looked in to.

Thanks,

NeilBrown

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20111221/fb9e34cb/attachment-0001.bin>


More information about the Gta04-owner mailing list