[Community] Goldelico Replicant initialisation

Lukas Maerdian luk at slyon.de
Wed Nov 5 11:43:52 CET 2014


Am 04.11.2014 um 17:27 schrieb Adrien Dorsaz:
> I've some time now to try to build Replicant and to make tests (I'm
> trying to build the Goldelico version).
> 
> It seems that I have successfully downloaded all sources, but I'm not
> able to begin the build process. Indeed when I run 'lunch
> replicant_gta04-eng' it says me :
> 
>> vendor/replicant/config/common_full.mk:5:
>> frameworks/base/data/sounds/NewAudio.mk: No file or folder of this type
>> vendor/replicant/config/common_full.mk:8:
>> frameworks/base/data/sounds/AudioPackageNewWave.mk: No file or folder
>> of this type
>> build/core/product_config.mk:239: ***
>> _nic.PRODUCTS.[[device/goldelico/gta04/cm.mk]]:
>> "frameworks/base/data/videos/VideoPackage2.mk" does not exist. Halt.
>>
>> ** Don't have a product spec for: 'replicant_gta04'
>> ** Do you have the right repo manifest?
> 
> I don't understand, because I've downloaded the proposed manifest of
> Goldelico website and I've installed it in the .repo/local_manifest
> directory.
> 
> Do you have some hint to solve this issue ?

Hello Adrien,

thanks for your interest! I've just updated my build Env to the latest
state (../tools/repo sync && vendor/replicant/get-prebuilts), but for me
every is still working as expected...

Some hints you could try:
1) try to update all the sources again:
../tools/repo sync
vendor/replicant/get-prebuilts

2) make sure you are executing all commands from within the
"replicant-4.2" directory

3) post your .repo/local_manifests/gta04.xml

HTH,
  Lukas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/community/attachments/20141105/83d7697e/attachment.asc>


More information about the Community mailing list